Jump to content
Marli

e-mail de cobranca

Recommended Posts

Boa Tarde!

Estou tentando mandar um email para cada cliente meu em aberto (vencidas e a vencer), para isso segui os procedimentos:

. Criei um relatorio com saida texto no Gerador;

. Fiz o filtro pedindo que Flan.status=0, e flan.receberpagar = receber

Rodei o relatorio em arquivo ele esta ok! traz todas as informações necessarias

Configurei a saida SMTP corretamente.

Entrei em utilitarios => envio email para clientes fornecedores => avancar

o RM pede para que eu defina um filtro do FCFO (tabela de clientes/fornecedores), porem nao tem nenhum campo nesta tabela que diga que o cliente esta com titulos em aberto...

se nao selecionar nenhum filtro, ele abre a janela com todos os clientes cadastrados, para que eu faca manualmente a seleção... estou falando de um universo de 800 clientes ativos contra uns 7000 cadastrados.

Se seleciono todos, ele mandara o relatorio para todos os clientes, independente de ter ou nao titulos em aberto, porem o email enviado para aqueles que nao tem titulos em aberto somente apresenta o cabeçalho.

Como fazer para que ele envie somente para os clientes com titulos em aberto?

Agradeço desde ja,

Marli

Share this post


Link to post
Share on other sites

Você pode fazer uma sentença e colocar nesse filtro [Cód Cli/Flor = (COBRANCA)].

um exemplo bem simples:

(COBRANCA)

SELECT DISTINCT CODCFO 
FROM FLAN 
WHERE STATUSLAN = 0 
AND PAGREC = 1 
AND CODCOLIGADA = 1

Outra desvantagem que achei dessa função é que você não pode editar o corpo do e-mail c/ arquivo anexo.

Passei essa solicitação de melhoria para RM e a posição que eles me deram que na versão 11.0 essa função já estará melhor.

Jamensson

Share this post


Link to post
Share on other sites

Olá Marli,

Por coincidência estou tentando fazer o mesmo processo que você, enviar a cobrança via e-mail, porém o relatório que criei não ficou bom, será que você pode disponibilizar o seu relatório de cobrança?

Att,

Desde já agradeço,

Tatiana

Share this post


Link to post
Share on other sites

Olá Marly, você conseguiu resolver esse problema do e-mail? Utilizo dessa forma aqui na empresa.

Qualquer dúvida é só avisar que te mando o relatório que eu estou utilizando.

att,

TatiDias

Share this post


Link to post
Share on other sites

Pessal, como vocês fazem para o nome do relatório criado aparecer quando marcam um lançamento no fluxus e clicam em enviar e-mail (envelopinho) e depois abilitam o anexo e quando vou selecionar o e-mail, bum! não tem nada lá....

O relatório está para gerar PDF e já o deixei como Genérico, Documento, etc.....

Só falta isso :cray:

Valeu galera e bom final de semana à todos

:victory:

Share this post


Link to post
Share on other sites
Pessal, como vocês fazem para o nome do relatório criado aparecer quando marcam um lançamento no fluxus e clicam em enviar e-mail (envelopinho) e depois abilitam o anexo e quando vou selecionar o e-mail, bum! não tem nada lá....

O relatório está para gerar PDF e já o deixei como Genérico, Documento, etc.....

Só falta isso :cray:

Valeu galera e bom final de semana à todos

:victory:

Robinson, lá no relatório tem que estar com o tipo de relatório = DOCUMENTO e o tipo de saída tem de ser PDF....

quando mandar enviar o email tem que selecionar a opção de Gerar Relatorio em PDF e enviar como anexo.... caso isso não esteja selecionado ele te deixa selecionar apenas os relatórios do tipo GENERICO e saída Texto....

Share this post


Link to post
Share on other sites

Olá Lugão.

Não deu certo Brother. :victory:

Configurei tudo doreitinho, tenho acesso ao grupo de relatório, mas o danado não aparece.

Olha as telas:


Carta de Cobrança 1 title="Carta de Cobrança 1 por pirata_x, no Flickr">5072029665_36dcbbfaf2.jpg
5072630244_b060cc9673.jpg

Robinson, lá no relatório tem que estar com o tipo de relatório = DOCUMENTO e o tipo de saída tem de ser PDF.... quando mandar enviar o email tem que selecionar a opção de Gerar Relatorio em PDF e enviar como anexo.... caso isso não esteja selecionado ele te deixa selecionar apenas os relatórios do tipo GENERICO e saída Texto....

Share this post


Link to post
Share on other sites
<P>Olá Lugão.

<BR>

<BR>

Não deu certo Brother. :victory:

<BR>

Configurei tudo doreitinho, tenho acesso ao grupo de relatório, mas o danado não aparece.

<BR>

Olha as telas:

<BR>

<BR>

<hr>

<a href=" Carta de Cobrança 1 title="Carta de Cobrança 1 por pirata_x, no Flickr">5072029665_36dcbbfaf2.jpg

<hr>

5072630244_b060cc9673.jpg

<hr>

<hr>

estranho, aqui comigo funciona bem apenas fazendo isso...

voce tem configurado conta de email nos parametros globais?

Share this post


Link to post
Share on other sites

É lugão, pior que isso também está configurado...

Cada surpresa que me acontece com o Corpore RM... :cray:

Quarta-feira vou tentar falar com o suporte da RM, vamos ver o que eles me falam.

Se lembrar de mais alguma coisa ficarei feliz e saber Lugão.

Valeu e bom feriado amigo.

:victory:

estranho, aqui comigo funciona bem apenas fazendo isso...

voce tem configurado conta de email nos parametros globais?

Share this post


Link to post
Share on other sites

Só mais uma coisa Lugão

Se eu for pelo menú Utilitários>Envio de e-mail clientes/fornecedores o relatório aparece e eu consigo selecioná-lo.

Só para quando eu estou na tela de lançamentos e seleciono um ou mais lançamentos para enviar e-mail de cobrança é que o danado não aparece :victory:

Tri loco!

estranho, aqui comigo funciona bem apenas fazendo isso...

voce tem configurado conta de email nos parametros globais?

Share this post


Link to post
Share on other sites
Só mais uma coisa Lugão

Se eu for pelo menú Utilitários>Envio de e-mail clientes/fornecedores o relatório aparece e eu consigo selecioná-lo.

Só para quando eu estou na tela de lançamentos e seleciono um ou mais lançamentos para enviar e-mail de cobrança é que o danado não aparece :victory:

Tri loco!

hum... esse usuário que você está utilizando é DBA (permissão máxima no sistema) ? tem acesso ao grupo do relatório para envio?

Share this post


Link to post
Share on other sites

É o DBA sim Lugão e neste perfil estão associados todos os grupos de relatórios em todos os aplicativos.

O Trêm é irado mesmo :-)

Vamos ver o que mais consigo descubrir :victory:

hum... esse usuário que você está utilizando é DBA (permissão máxima no sistema) ? tem acesso ao grupo do relatório para envio?

Share this post


Link to post
Share on other sites
É o DBA sim Lugão e neste perfil estão associados todos os grupos de relatórios em todos os aplicativos.

O Trêm é irado mesmo :-)

Vamos ver o que mais consigo descubrir :victory:

olha só o sql que o processo faz:

SELECT DISTINCT RRELAT.ID, RRELAT.CODRELATORIO, RRELAT.DESCRELATORIO, RRELAT.CODCOLIGADA FROM RRELAT, RRELTIP, RCAMREL WHERE RRELTIP.CODAPLIC = ? AND (RRELAT.CODCOLIGADA = 0 OR RRELAT.CODCOLIGADA = ?) AND RRELAT.TIPOSAIDA = ? AND RRELAT.IDTIPORELATORIO = RRELTIP.ID AND EXISTS (SELECT 1 FROM RCAMREL WHERE RCAMREL.CODCOLIGADA = RRELAT.CODCOLIGADA AND RCAMREL.IDRELATORIO = RRELAT.ID AND RCAMREL.DESCCAMPO = ?) AND EXISTS (SELECT 1 FROM RCAMREL WHERE RCAMREL.CODCOLIGADA = RRELAT.CODCOLIGADA AND RCAMREL.IDRELATORIO = RRELAT.ID AND RCAMREL.DESCCAMPO = ?) AND EXISTS (SELECT 1 FROM RCAMREL WHERE RCAMREL.CODCOLIGADA = RRELAT.CODCOLIGADA AND RCAMREL.IDRELATORIO = RRELAT.ID AND RCAMREL.DESCCAMPO = ?)

dos campos que eu disse apenas faltou conferir se o relatório está na mesma coligada que o lançamento que está tentando imprimir... voce olhou isso?

Share this post


Link to post
Share on other sites

Pessal, como vocês fazem para o nome do relatório criado aparecer quando marcam um lançamento no fluxus e clicam em enviar e-mail (envelopinho) e depois abilitam o anexo e quando vou selecionar o e-mail, bum! não tem nada lá....

O relatório está para gerar PDF e já o deixei como Genérico, Documento, etc.....

Só falta isso :cray:

Valeu galera e bom final de semana à todos

:victory:

Robinson

com posso habilitar o (envelopinho) está inativo eu já vasculhei todos os parâmetros do Fluxus e não consegui encontrar.

Share this post


Link to post
Share on other sites

Olá Osiel

Esse envelopinho é o que aparece na barra de ferramentas do aplicativo.

Para que ele apareça você tem que dar acesso no perfil do usuário em menus.

:victory:

Robinson

com posso habilitar o (envelopinho) está inativo eu já vasculhei todos os parâmetros do Fluxus e não consegui encontrar.

Share this post


Link to post
Share on other sites

Olá Osiel

Esse envelopinho é o que aparece na barra de ferramentas do aplicativo.

Para que ele apareça você tem que dar acesso no perfil do usuário em menus.

:victory:

blz.

Obrigado.

verifiquei todos os parâmetros do Fluxos, mas não me atentei ao perfil.

valeu.

Share this post


Link to post
Share on other sites

blz.

Obrigado.

verifiquei todos os parâmetros do Fluxos, mas não me atentei ao perfil.

valeu.

robinson,

mesmo utilizando perfil DBA nao consigo habilitar o envelopinho. existe mais algum parametro que devo verificar?

obrigado.

Share this post


Link to post
Share on other sites
Em ‎13‎/‎10‎/‎2010 at 07:11, lugao disse:

hum... esse usuário que você está utilizando é DBA (permissão máxima no sistema) ? tem acesso ao grupo do relatório para envio?

Robinsom, boa tarde!

 

Eu não achei esse caminho no utilitários do RM Fluxus.

 

Em ‎13‎/‎07‎/‎2012 at 15:47, osiel73150 disse:

robinson,

mesmo utilizando perfil DBA nao consigo habilitar o envelopinho. existe mais algum parametro que devo verificar?

obrigado.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.